How to install roxterm on Xubuntu 18.04.1 LTS

roxterm no longer exist in debian pkg

Download and install roxterm using source below

http://roxterm.sourceforge.net/index.php?page=installation&lang=en

git clone git://git.code.sf.net/p/roxterm/code roxterm

cd roxterm

Install python if needed:

sudo apt install python

You may skip below three steps and install and install dependencies firstly

sudo python ./mscript.py configure
sudo python ./mscript.py build
sudo python ./mscript.py install

Dependencies:

sudo apt-get install libgtk-3-dev -y

if appears po4a-gettextize not found and other

sudo apt-get install po4a -y
sudo apt-get install itstool -y

sudo apt-get install libvte-2.91-dev

dbus-glib-1

sudo apt-get install libdbus-glib-1-dev -y

OSError

sudo apt install libtool-bin -y

wget https://bootstrap.pypa.io/ez_setup.py -O - | sudo python

Install lockfile pkg

wget https://pypi.python.org/packages/source/l/lockfile/lockfile-0.10.2.tar.gz#md5=1aa6175a6d57f082cd12e7ac6102ab15

sudo python setup.py install -y

sudo apt-get install libvte-2.91-dev -y

if needed here is 2.90

https://launchpad.net/ubuntu/xenial/amd64/libvte-2.90-dev/1:0.36.3-1ubuntu2

 

Similar Posts:

4 comments on “How to install roxterm on Xubuntu 18.04.1 LTS

  1. Hello,

    Please add the following command the first step

    sudo apt install python

    Since not all users have python installed

Leave a Reply

Your email address will not be published.